Compared with Kylin 3.x and previous versions, Kylin 4.0’s storage engine has changed from HBase to Parquet. Therefore, if you need to upgrade from Kylin 3.x and previous versions to kylin4.0, the built cuboid data can’t be upgraded, you can only upgrade metadata.

Please refer to : How to migrate metadata to Kylin 4